configure: error: Package requirements (oniguruma) were not met

Asked 4 weeks ago, Updated 4 weeks ago, 25 views

When I try to install php, the following error appears.

configure: error: Package requirements (oniguruma) were not met

 I'm currently using Rocky Linux 8(CentOS8).

If I searched this problem, it said to run as below, but I couldn't.

sudo yum install -y oniguruma-devel

Is there any idea for this? 

php rockylinux8 centos8

2022-07-10 12:57

1 Answers

You can install it by running it as below.

dnf --enablerepo=powertools install oniguruma-devel


2022-07-10 12:57

If you have any answers or tips


© 2022 pinfo. All rights reserved.